内网 IP 段 192.168.1.0/24 网关 192.168.1.1
隧道 IP 段 10.0.0.0/24 网关 10.0.0.1

# 创建 IP 列表
/ip firewall address-list
add list=DNS address=1.0.0.0/24
add list=DNS address=1.1.1.0/24
add list=DNS address=8.8.8.0/24
add list=DNS address=8.8.4.0/24

# 隧道出口路由
/ip route
add dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_wg1

# NAT
/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24 out-interface=wg1 action=masquerade

# 标记数据包
/ip firewall mangle
add chain=prerouting src-address=192.168.1.0/24 dst-address-list=DNS protocol=udp action=mark-routing new-routing-mark=to_wg1 passthrough=yes
最后修改:2021 年 05 月 14 日 06 : 40 PM